Unable to install add-on

Hi team,

I’m not able to install Charts/Reporting/legacy BPM addon via Studio 14:
project information:
prod version:


Seems that the issue caused by the Chinese translation of marketplace. So the search by English word “charts” doesn’t perform as you expect.
Try to search by some Chinese keyword or just find the add-on in the list manually.

The YouTrack issue created. We will think how we can improve search usability for this case.

Thanks Alexander, but I tried with Chinese character, still fail to list Charts add-on. Could you please let me know from where Studio is fetch the list of addons?


You are right. There are an issue with available add-ons list. Compatibility information is missing for some add-ons. So they are not shown in the list of add-ons compatible with the current CUBA version.

Our team is working on solving the issue.
As a temporary workaround you can switch to EN locale.
Go to Help -> Edit Custom VM Options… and put -Duser.country=EN.
Restart IDE.
Then worldwide add-ons list should be used, that doesn’t have this missing information issue.