How to enable DEBUG log level in Studio

Hi ,

For debugging an issue about custom database , i need check some logs of DEBUG level in Studio.
How to enable DEBUG log level in Studio?
Following is my setting in IDEA, but no any effects.
image

Please suggest.

Hi,
Try Main Menu -> CUBA -> Advanced -> Enable DEBUG logging Level

Hi Alex,

When enable CUBA Studio DEBUG loggging level,
i can see some DEBUG level logs,but seems only a part of DEBUG logs are output.
See the attachment, no any DEBUG logs of com.haulmont.studio.backend.ed.ddl.DbManager,only some DEBUG logs of tellij.ui.cubatree.CubaSection.

idea (1).log (741.6 KB)

Are you sure there should be log messages from DbManager?
What actions you were performing? We will check in the source code.

See this screenshot, it indicated the actions :
image

The original problem is from chinese forum.

Hi, @lugreen!
Have you defined and configured a custom database? (CUBA -> Advanced -> Define Custom Database)?
If yes, please attach the following files (informix - my custom database name):
modules.core.src.com.haulmont.studio.db.informix
DdlGeneratorDelegate.groovy
InformixDdlGenerator.groovy
InformixDbProperties.groovy

DdlGeneratorDelegate.groovy (11.2 KB) GbaseDbProperties.groovy (8.3 KB) GbaseDdlGenerator.groovy (30.6 KB)

数据库的名称是gbase

Hi Alexander,

Thank you. The developer have uploaded the files.

  1. The Chinese forum says that the task updateDB is successful. But, for its successful execution, init database scripts must be generated for system entities (User, Group, Role, etc…) and for entities from the project. Do scripts really exist?
  2. Based on the exception (java.net.SocketTimeoutException: connect timed out), try increasing the GbaseDbProperties#getLoginTimeout parameter to ~ 20, for example.
  3. With the JDBC driver’s all right, because the error is returned to them. com.informix.asf.IfxASFException - class from the driver.
  4. Can you connect to the local server (localhost)?
  5. What version of Informix are you using?
1 Like

Hi @zlatoverov,

Thanks for your suggestion. The developer said that the problem disappeared after increasing the Timeout.

Ray,
Regard