Application Server not running after implementing the "Maps" addon

Hi there,

I am migrating the maps I have made with the “Charts” addon to the commercial version of the “Maps” addon, but when I run the application I run into the following error:

Task :app-web-toolkit:buildWidgetSet
Compiling module com.myproject.web.toolkit.ui.AppWidgetSet
[ERROR] Hint: Check that your module inherits ‘com.google.gwt.core.Core’ either directly or indirectly (most often by inheriting module ‘com.google.gwt.user.User’)

Task :app-web-toolkit:buildWidgetSet FAILED

Execution failed for task ‘:app-web-toolkit:buildWidgetSet’.
Process ‘command ‘C:\Program Files\Java\jdk1.8.0_231\bin\java.exe’’ finished with non-zero exit value 1

I have been seeing forums for a week that may have changes depending on the version, so I am currently using the Java 8 version.

Any idea how to fix it?

4 Likes

Hi, @dmateube

Could you please provide us with this information:

  1. Your CUBA Platform and CUBA Studio versions. This can be easily copied in CUBA -> Welcome -> Product Versions.
  2. Maps addon version.
  3. Your AppWidgetSet.gwt.xml file located in the web-toolkit module.

Regards,
Gleb

Hi,

CUBA Platform version (7.1.5)
image

CUBA Studio version (12.3-191)
image

Maps addon version(1.1.0)
image

AppWidgetSet.gwt.xml file:
AppWidgetSet.gwt.xml (277 Bytes)

Thank you very much.

2 Likes

Hi, @dmateube

Unfortunately, we can not reproduce the issue. Could you please provide a demo project in which the error is reproduced?
Also, this information can be helpful:

  1. Your JDK version. I have noticed from your first message that you use Java 8, but maybe you changed the version recently?
  2. Gradle JVM version. In the Intellij IDEA can be found in: Preferences | Build, Execution, Deployment | Build Tools | Gradle.

Regards,
Gleb

Hi and thank you for the tracking of the issue.

1.- I am sorry but I cannot share the project because it is a corporate application. What I can do is try to replicate the error in a separate project. I will do that and I let you know ASAP the result.

2.- We are using the JDK 8
image
What we do is the following:

A) 2 upgrades
a. The first one from version 7.0.11 to 7.1
b. The second one from version 7.1 to 7.1.5
B) In order to be able to execute the maps addon we commented in our gradle script the following line (mavenCentral())
image
If we don’t delete this line the compiling fails. There is a problem with the Maps addon and MavenCentral.

3.- We are using the 6.0.1 gradle version. We installed manually this version because the version installed inside of IntelliJ IDEA fails with our code.
image

Finally, can we use the Charts addon and Maps addon at the same time?
I think there is a problem between these two.