Gradle groovy.lang.MissingPropertyException outputDir


(Phileo Kazavanga) #1

Hi,
I recently updated my cuba platform, I am using 6.8.1 now.
Whenever I try to run the server I always get this error:

groovy.lang.MissingPropertyException: No such property: outputDir for class: org.gradle.api.internal.file.DefaultSourceDirectorySet

Is there a way of solving this problem?


(Yuriy Artamonov) #2

Hi,

Which version of Gradle do you use? Since 6.8 platform requires 4.3+


(Phileo Kazavanga) #3

Hi,

I had 3.4.1
But i just updated to 4.6
However I still have the same error.


(Yuriy Artamonov) #4

Do you use Studio or start tasks from command line?


(Phileo Kazavanga) #5

Currently I am using Studio


(Yuriy Artamonov) #6

Did you specify Gradle version in Studio? It is not necessary any more since Studio will use the right version of the Gradle depending on project.


(Phileo Kazavanga) #7

No, as far as I’m concerned I only specified the version in the build.gradle file.


(Yuriy Artamonov) #8

It should be in gradle/gradle.properties instead and not in the build.gradle. Version in build.gradle is used only for Gradlew generation


(Phileo Kazavanga) #9

Hi
Yes, it also in a gradle-wrapper.properties file.


(Phileo Kazavanga) #10

Hi,
I resolved it. I didn’t change my gradle installation directory in the studio settings when I updated to another gradle version.


(Yuriy Artamonov) #11

I’d recommend to simply reset it. It is not required any more because Studio will download appropriate Gradle automatically depending on Project properties and used platform version.


(Rene) #12

Hi! How do I reset the gradle installation directory?


(Yuriy Artamonov) #13

Check Studio settings: