Application is hanging when adding a search condition by a transient attribute with @MetaProperty(related =

Hi,

Our platform is:
CUBA Platform version: 7.2.4
CUBA Studio plugin version: 13.2-191
IntelliJ version: CUBA Studio 2019.2

Our project has a main data store and the additional data store where entities tables from an app component are located in. Therefore, our project has association relationship with entities that belong to an app component and tables are locate in the additional data store.

Due to following bug in Studio, https://youtrack.cuba-platform.com/issue/STUDIO-8341, we’ve set up cross data store reference manually:

   @SystemLevel
    @Column(name = "ID_ADRECA")
    private Integer adrecaId;

    @Transient
    @MetaProperty(related = "adrecaId")
    private Adreces adrAcces;

This reference works fine with this attribute in all forms created however the application is hanging when adding a search condition by this attribute in a browser form, as it’s shown on next screen capture:
application is hunging

Is there any workaround to apply? Any suggestion?

Regards,

Xavier

Hi, Cuba Platfom’s support

I would be very grateful if you could suggest me any solution to avoid this problem because this field is functionally important for users and they need to filter information by this value.

Thanks in advance.

Regards,

Xavier

Hi,

Finally, without any answer to solve it, we’ve just decided to make redundant on the database the attribute needed to do searchs, creating in the entity an attribut and assigning the corresponding value on “before commit” event:

// Abans de gravar informem la Adreça a la solicitud, per poder fer recerques amb ella
            solicitud.setAdrAccesDsc(adrecesService.tornaAdr1(solicitud.getAdrecaId()));
            dataContext.merge(solicitud);
            event.resume();        // Commit

Please, I trust you will fix this bug in resolving the following issue https://youtrack.cuba-platform.com/issue/STUDIO-8341

Regards,

Xavier Lorente

Hi.
Unfortunately, I cannot reproduce the problem. I’ve tried several databases, but all works fine for me. Maybe, it’s because these bases are small.

If it’s possible, could you check app log for exceptions? Or maybe you can send us a small sample project?

Regards,
Natalia